Gain extra benefits by becoming a Supporting Member Click here find out how!

Classic Performance Products Classic Industries
American Auto Wire
Danchuk Catalog
Hellwig Products IncPerformance Rod & CustomNu-Relics Power Windows



Username Post: Powerglide ?
ragtp66 
Contributor
Posts: 909

Reg: 12-09-07
02-05-19 08:15 PM - Post#2759159    
    In response to PLS

That kind of looks like rust probably from inside the metal vacuum line that goes up to the manifold. You can blow some compressed air through it to clean it out. If it doesn't flow easily or seems plugged up it may need to be replaced or at least cleaned out. Could try clr or some Muriatic acid and a funnel just be careful with the acid wear safety glasses and some gloves. Plug one end and slowly add the acid or clr to fill the tube. You can check the modulator if you have a mityvac pump or just a length of rubber hose and suck on it and see if it holds a vacuum or not. The diaphram might not be ruptured if its not leaking fluid out but it is possible the spring in it is no good. I don't think it will hurt anything running the fluid you have in it but the type F fluid is about as close as you can get to the original type fluid.

Give David a call at: http://autotran.us/ I bought all my parts from him for my cast glide he was VERY helpful and knowledgeable
Toys:
1958 Impala 2dr Hardtop Under Construction
1966 Chevelle Malibu Convert M20/350 Aztec Bronze
1987 Sea Ray Pachanga 22
2002 Cadillac Escalade EXT Parts chaser
2007 Trailblazer SS -gone and missed

NOTE: You are viewing an individual Post. View the Entire Topic
FusionBB
FusionBB™ Version 2.1
©2003-2006 InteractivePHP, Inc.
Execution time: 0.214 seconds.   Total Queries: 13   Zlib Compression is on.
All times are (GMT -0800) Pacific. Current time is 01:01 AM
Top