Gain extra benefits by becoming a Supporting Member Click here find out how!
Silver
Gold ***Platinum***
impalagirlA White Sport Coupe (4)rods46truck
farmerdick jsanctuarymarccan2Paradox SammyJohns winstead
ChevyGuy78trcunnigusukchevy55 (3)56_Kruiser (3)57 Kevin (5)
jdicamillomoritzdds
Bowtie_Guy (6)
bajones238 (4)
65 Malibu
smokinjoe65SS (2)

YellowSub (5)
turbo38s10 (4)
Classic Performance Products
Ciadella Interiors American Auto Wire Art Morrison.com
Exile® Battery Keeper™ 6/12 volt charger w/ LED battery monitor
Hellwig Products IncPerformance Rod & Custom
Impala Bob's Bob's Chevy Trucks Bob's Chevelle Parts Bob's Classic Chevy

  >> Switch to Mobile Version <<

Recent Hot Topics
Current Quote
"Looking forward to ploughing thru the wealth of information the site has to offer."
~ New Member
Recent Topics
Join the Community today







Username Post: 1988 chevy cheyenne won't start        (Topic#261893)
bradleigh 
Forum Newbie
Posts: 5

Reg: 04-25-11
04-25-11 04:28 PM - Post#2081775    

I have a 1988 chevy cheyenne 4x4 pickup.v8 5.0L 1/2 ton. my husband hit a deer last fall, and we have replaced the front end and driver side fender. the head lights work but no other lights, on dash or hazard, blinker or even the radio will work. when we trun the key we get nothing. we had the starter tested, and changed the igition switch and still nothing. when we towed the truck back home it started and we were able to back it in the yard so it worked then. does any one know what could be wrong with it? thanks



 
355Cheyenne 
Senior Member
Posts: 3765
355Cheyenne
Loc: Northern MN
Reg: 10-27-04
04-26-11 02:03 PM - Post#2082285    
    In response to bradleigh

Check all ground cables. From the battery on the negative post there should be a small wire that goes from the battery to the passenger side fender right next to the batter. There should be a large cable that runs to the motor and a strap from the motor to the frame. There are a lot more grounds but I suspect it is one of those two. Also I would have the battery tested. The accident could have damaged the battery.
98 Silverado k1500 4x4 350


 
Thunderkid89 
Forum Newbie
Posts: 17
Thunderkid89
Loc: Oklahoma
Reg: 04-27-11
04-27-11 11:48 AM - Post#2082762    
    In response to bradleigh

I just had this happen on my 88 silverado. I had the starter tested and they said it was fine, I had a hunch it was the solenoid so I replaced it since it was a cheap fix. The truck started right up. It is possible though that when I took the starter and Solenoid off I just gave it a better connection. It's worth a shot, I hope it helps because for me it was cheap and easy!
1988 Chevy Silverado 2500 4x4, 5.7 L , 350 V8, 166 k miles
1999 Chevy Silverado 1500 Z71 5.3 L, V8, 270 k miles


 
bradleigh 
Forum Newbie
Posts: 5

Reg: 04-25-11
05-01-11 01:06 PM - Post#2084518    
    In response to 355Cheyenne

My husband checked all the ground wire you mentioned. he also changed the battery positive and nevitive cables and we still get nothing when he turns the key.

 
bradleigh 
Forum Newbie
Posts: 5

Reg: 04-25-11
05-01-11 02:06 PM - Post#2084542    
    In response to bradleigh

Would a bad ground on the solenoid cause the dash lights and radio not to work?

I'm not getting any dash lights with the key in on postion, no fuel pump sounds, checked all fuses.

Not sure of power flow through battery/starter/switch. Anyone have a wiring diagram I might look at? I'm thinking it could be the solenoid as Thunderkid said if that would prevent the dash lights and radio not to work as well.

Thanks.

 
CowboyTrukr 
"3rd Year" Silver Supporting Member
Posts: 1727
CowboyTrukr
Loc: Salt Lake City
Reg: 06-20-09
05-01-11 07:06 PM - Post#2084761    
    In response to bradleigh

Aside from a service manual, you can pull stuff up on some of the parts store web sites.
'94 Silverado K2500 4X4 5.7 5spd Xcab LB. SOLD. :-(
'00 Contour SE 2.5 24V

"The only thing necessary for evil to triumph is for good men to do nothing" Sir Edmund Burke


 
355Cheyenne 
Senior Member
Posts: 3765
355Cheyenne
Loc: Northern MN
Reg: 10-27-04
05-02-11 06:04 AM - Post#2084980    
    In response to bradleigh

Pull the battery and take it to a shop to get tested. I suspect it has a broken plate internally and should show up on a test.
98 Silverado k1500 4x4 350


 
bradleigh 
Forum Newbie
Posts: 5

Reg: 04-25-11
05-26-11 09:54 AM - Post#2095292    
    In response to 355Cheyenne

Thank you all for your help, we did everthing what was sujested. we finaly got the truck running. A friend of ours told my husbsnd to tap on the alternator, because it might be stuck. when he did it started to turn over, but ten the battery went dead. when charged enogh to try again, it wouldn't do anything. we noticed the wireing harness on the fire wall that leads to the fuse box and ignition switch ect..was loose, my husband tightened the wireing harness that is against the fire wall and then tapped on the alternator again and it started, and then we needed a new battery. again thanks to all.

 
Icon Legend Permissions Topic Options
Report Post

Quote Post

Quick Reply

Print Topic

Email Topic

4201 Views
FusionBB
FusionBB™ Version 2.1
©2003-2006 InteractivePHP, Inc.
Execution time: 1.042 seconds.   Total Queries: 17   Zlib Compression is on.
All times are (GMT -0800) Pacific. Current time is 11:14 AM
Top